0.196.0 failing to start? 🤔


the newest n8n version (0.196.0) won’t start. I’ve tried running it from docker …

docker run -it --rm --name n8n -p 5678:5678 n8nio/n8n:latest

… and got following output

UserSettings were generated and saved to: /home/node/.n8n/config
query is slow: CREATE TABLE "migrations" ("id" integer PRIMARY KEY AUTOINCREMENT NOT NULL, "timestamp" bigint NOT NULL, "name" varchar NOT NULL)
execution time: 3338
Migrations in progress, please do NOT stop the process.
Migrations finished.
 ›   Error: There was an error: EACCES: permission denied, mkdir '/usr/local/lib/node_modules/n8n/dist/public'

P.S.: My system is arm64

Can you please make sure to pull again:

docker pull n8nio/n8n:latest

I did that before raising this question, but same error was displayed.

After your suggestion @jan I deleted the image and pulled again (same image from ~5hours ago was pulled) and everything is working again!

Sorry for bothering.

Very strange. Wonder why that did not work directly. But glad that it started to work after you deleted the faulty one.

Starting docker container locally Error: There was an error: EACCES: permission denied, mkdir › '/usr/local/lib/node_modules/n8n/dist/public'

I have hit the same issue on 3.Oct.2022 and followed the instruction

  • Pulling the latest but still having the same issue.
  • deleted previous image and build the image with docker build --no-cache -t n8n-listener .

Is there anything else I can try to get it started locally? Cheers



I did that for resolv:
chown node:node -R /usr/local/lib/node_modules/n8n

1 Like