'2024-02-04T23:21:20' isn't a valid date and time

Hello, when i try to get emails from gmail, that are received after a specific date i receive this error:

NodeOperationError: [RE-WRAPPED]: Invalid date/time in 'Received After' field (item 0)
    at Object.execute (/usr/local/lib/node_modules/n8n/node_modules/n8n-nodes-base/dist/nodes/Google/Gmail/v2/GmailV2.node.js:525:23)
    at Workflow.runNode (/usr/local/lib/node_modules/n8n/node_modules/n8n-workflow/dist/Workflow.js:706:42)
    at /usr/local/lib/node_modules/n8n/node_modules/n8n-core/dist/WorkflowExecute.js:656:68
    at processTicksAndRejections (node:internal/process/task_queues:95:5)
    at /usr/local/lib/node_modules/n8n/node_modules

The strange part is that sometimes it works but othertimes it does not . I run N8n in queue mode, maybe it can be one of the reasons

 n8n-worker1:
    <<: *shared
    command: worker --concurrency=20
    depends_on:
      - n8n

I have n8n 1.27.2

It looks like your topic is missing some important information. Could you provide the following if applicable.

  • n8n version:
  • Database (default: SQLite):
  • n8n EXECUTIONS_PROCESS setting (default: own, main):
  • Running n8n via (Docker, npm, n8n cloud, desktop app):
  • Operating system:

@Victor_Sava , are you using an expression in “Received After” field? Generally speaking, according to ISO 8601, the date and time value should have timezone included. That is, not just 2024-02-04T23:21:20 but rather 2024-02-04T23:21:20Z or 2024-02-04T23:21:20+00:00 (for UTC), for example.

The IF node also has an error with date comparison. Less strict type validation does not help. Version 1.26.0