A webhook with the identical URL exists already. Please delete it manually on Github!

I’m at a loss. Everything was working but now it’s impossible to start my workflow with the GitHub triggers.

A webhook with the identical URL exists already. Please delete it manually on Github!

I’ve tried

  • generating a new GitHub token
  • deleting all webhooks through GitHub’s API with postman
  • giving it a long time to reset itself (unfortunately, that didn’t work)

Here’s where the error is being created. n8n/GithubTrigger.node.ts at 291d405a121f3e893a2cff2d0c0f4ccd2c27ba25 · n8n-io/n8n · GitHub

Have to have a deeper look into that to avoid such problems in the future.

For now. n8n normally deletes all Webhooks when it gets turned off. It seems that this did not happen for some unknown reason. The fix should be to simply delete the already existing webhook.

There should be no need to do that via Postman you can do it directly via the settings page (Settings → Webhooks) of your Github repository. The URL will be in this format:
(The above will not work as you are not part of n8n, is just an example)

Once it is deleted you should be able to simply deactivate and activate the workflow again.

I’m going to look into this further. All webhooks are deleted on all my repos. I went to https://github.com/user/repo/settings/hooks like you said

Great, if you did that the problem should be fixed.

It’s still not working. Give me a minute though I might have found the problem

Okay the problem was that I had also broken the webhooks’ endpoint. I’m moving to a production server right now. I guess it was just giving a misleading error…

Cool, fingers are crossed.

1 Like

Off topic now…but…

I’m running n8n on a home mac mini and then ssh-ing localhost from the mac mini to my server. I’ve managed to use nginx to expose the UI on the server with https, and that’s all working.

But now I don’t know how to expose the webhooks endpoint on the server? I’m not even sure where n8n expects the webhooks url to be either. Any pointers? I’m new to a lot of this.

I guess if you did expose the UI you also exposed the webhook endpoints with it.

Anyway here is an older discussion about nginx setup which could maybe help you:

1 Like

Okay, I noticed export WEBHOOK_TUNNEL_URL doesn’t work. I’m going to make another thread about it. That might be the source of my problem.

I got the webhooks working on my server once I hardcoded the base url for the webhooks in WebhookHelpers.js. I think it’s not currently picking up the WEBHOOK_TUNNEL_URL env var. Here’s a post I made about it.

Did commit a fix that if an identical webhook already exists it simply reuses it: