Accessing n8n workflow via docker on EC2 instance

Hello Everyone,

I hope your day is going well. I followed the documentation regarding the server setup for n8n and was able to get it to launch via local workstation “127.0.0.1:5678” which was a success!! I am now trying to implement the same thing on an EC2 instance via AWS.

I was able to run: sudo docker-compse up -d and can see the running process:

However I can’t seem to access it via browser when I enter the public IP address with port 5678.

I’ve opened ports, 80, 443, and 5678 via the security group, but that doesn’t seem to work. I tested out “Run with Docker” from the Quick start guide which worked out pretty well, however that’s not the case for the server setup. I feel like I am missing something when trying to access n8nio/n8n via the container inside the instance. I would appreciate any advise on this subject. Thank you.

Welcome to the community @silver!

Did you follow the server setup guide? Because you should have n8n running via an own subdomain rather than an IP via SSL. If you use an IP address you can expect to have problems with many third party services.

Hi Jan,

I appreciate your reply and thanks for allowing me to join the community. I did follow the server setup guide that is on n8n site: Server Setup | Docs. I left the configurations the same when creating the .env file that’s in the article. Here’s a snapshot of the env file.

Would I have to create a new subdomain inside the Ubuntu instance and reference it as “n8n” and modify the DNS setup on the server? I feel like I am missing certain configurations when trying to set this up on AWS but not sure exactly where. Please let me know.

Also these were the commands that I ran on the server during the setup:

Again I do feel like there is something missing regarding AWS. I tried this before setting up n8n on WSL which went pretty well. But my objective would be to set this up on a remote instance so it’s not dependent on my primary machine.