Add column values when creating monday.com item

Hi everyone,

I’m trying to create an item in monday.com with prefilled column values but I’m not able to get the JSON correct… (I’m quite new to this so possibly a super easy fix, idk…)

I’m getting this error:

Problem in node ‘Create item in “Client Overview” | Monday.com

Cannot read properties of undefined (reading ‘create_item’)

Here is the node:

Information on your n8n setup

  • n8n version:: 1.27.2
  • Running n8n via (Docker, npm, n8n cloud, desktop app): Docker
  • n8n EXECUTIONS_PROCESS setting (default: own, main): default
  • Operating system: I don’t know

It looks like your topic is missing some important information. Could you provide the following if applicable.

  • n8n version:
  • Database (default: SQLite):
  • n8n EXECUTIONS_PROCESS setting (default: own, main):
  • Running n8n via (Docker, npm, n8n cloud, desktop app):
  • Operating system:

Hey @pkovereng,

I suspect you are seeing a bug that we are tracking as NODE-1102 but to confirm are you using OAuth or an Access Token?

If you are using OAuth try swapping to an access token and you should be good to go.

1 Like

Thanks for the help @Jon.

Tried using the API access token now but same error. Could it be that I’m writing the JSON wrong or something like that?

Hey @pkovereng,

The JSON looks ok to me, I am surprised you have the same error with the access token though that seems to be ok in my test.

I wonder if there is another permission that needs to be set for the token for it to work.