Add option to ignore SSL issues on the Gotify node

My use case:

I’m using a self hosted Gotify instance which does not have a valid certificate (internal network, so no Let’s Encrypt). The Gotify node fails to create a message because of SSL issues.

My workaround for this is to use the HTTP Request node with the “Ignore SSL issues” option enabled. But I’d like to use the Gotify node to create Gotify messages. :slight_smile:

Any resources to support this?

Hi @rob_otter

There you go: feat(Gotify Node): Add Ignore SSL Issues by bramkn · Pull Request #6053 · n8n-io/n8n · GitHub


That went quickly, thanks! :slight_smile:


New version [email protected] got released which includes the GitHub PR 6053.


Unfortunately this does not work :frowning:

I’ve activated the Ignore SSL Issues in the Gotify Credentials configuration, but still getting the following error.

NodeApiError: self signed certificate
    at Object.gotifyApiRequest (/usr/local/lib/node_modules/n8n/node_modules/n8n-nodes-base/dist/nodes/Gotify/GenericFunctions.js:26:15)

Hey @rob_otter,

That is a bit unexpected, I will take a look next week and see if something is missing.

Hi @Jon,
did you had time to take a look at it? It still does not work with the current latest version.

Hey @rob_otter,

I didn’t but out of interest if you set the Ignore SSL option to false does it then work?

Interesting, if I set the option to false, I am getting a different error.

ERROR: The resource you are requesting could not be found
404 - {"error":"Not Found","errorCode":404,"errorDescription":"page not found"} - Not Found
NodeApiError: The resource you are requesting could not be found

@Jon I’ve tried it now with valid TLS and still getting the “Not Found” error.
So I think the Gotify credential is broken.

@rob_otter The 404 error you received is unrelated to SSL/TLS. It means the resource you’re trying to access, likely the gotify server, is unavailable or cannot be reached. Can you confirm if the gotify server is reachable from your n8n host/instance?

@CristianG I’ve checked everything multiple times.
Ping works, DNS resolution works, also the manual POST HTTP request, which I’m using as a workaround works.

But thanks to your hint, I’ve found the error: the URL in the Gotify credentials configuration must not end with a slash. So after I removed the trailing slash it finally worked.
Maybe It’s worth fixing or at least mentioning it in the docs.

Since I now have a valid certificate (thanks to Let’s encrypt), I can not test the option to ignore SSL.

1 Like

Not a problem, I have a way to test it now. I will update the credential to handle trailing slashes as well.