AI Agent (SQL Agent) seems to require a secure connection - can this be disabled?

I’m using my own locally hosted MariaDB, but I can’t get the SQL Agent to connect because it requires a secure connection. Can this be disabled somewhere?