App blocked when I try the Oauth2

Describe the issue/error/question

I’m trying to configure the oauth for google and youtube, Already created the credentials, but when I add it to the n8n hosted on a vps, and click to sign and select the same account that is configured on cloud console, it says that the app is blocked

What is the error message (if any)?

Este app está bloqueado

Este app tentou acessar informações confidenciais na sua Conta do Google. Para manter sua conta segura, o Google bloqueou o acesso.

Please share the workflow

(Select the nodes and use the keyboard shortcuts CMD+C/CTRL+C and CMD+V/CTRL+V to copy and paste the workflow respectively)

Share the output returned by the last node

Information on your n8n setup

  • n8n version: 0.195.5
  • Database you’re using (default: SQLite): sqlite
  • Running n8n with the execution process [own(default), main]:
  • Running n8n via [Docker, npm,, desktop app]: docker

Hey @Rafael_Tuneca,

Welcome to the community :raised_hands:

It sounds like an issue on the Google side, do you have a screenshot of the error and have you double checked the configuration in the google console?


Here’s the screenshots

I checked the google console, but google haven´t validated the consent screen, I could not find the advanced setting that says on the guide for this case in: Google: OAuth2 single service - n8n Documentation

Hey @Rafael_Tuneca,

Verification shouldn’t matter unless you are trying to use a different account but you could also add the account to the allowed users list in the app.

Out of interest are you using a Google Workplace account?

hi!, no, is not a workspace account

I am running out of ideas, If you go to the console and check the app under oauth consent screen is it marked as testing or internal?

I can’t select as internal, the console wont allow it

That is fine, is there any other settings in there? Normally it just works so I am not sure what is missing.

It might be worth making another app and making sure the urls are correct.