Attaching two files to an email not working


I’m trying to attached two files to an email, but it will only attach one.

I have an pdf that I’m downloading from S3 (saved to reportdata property) and a spreadsheet that I generate from a MySQL query (saved to actiondata binary property).

I’m attaching them to an email, putting a comma between each binary property and it just won’t work, no matter what I do. I only get one file attached.

Can you see what I’m doing wrong?


Can you share a picture of the spreadsheet node? Especially the binary tab (top right)

Here you go. Nothing special - when I click on show binary data it doesn’t show a preview of a csv though, where as the pdf file does.

As you can see, the only file you have available is the csv at that point. Use a Merge node with the merge by index operation. That should do it. Also, make sure the attachments in the Send Email node do not have spaces. For example, reportdata,actiondata

Worked like a charm - thanks @RicardoE105.

I didn’t realise that the binary property was only available to immediately connected nodes.

Great that it worked. Have fun.