Beginners course notify the team issue

{{$node["HTTP Request"].parameter["headerParametersUi"]["parameter"][0]["value"]}} returns the expected value, except it is proceeded by “=”, ex:

  • uniqueId: xxxx
  • return: =xxxx

I’m working thru the beginners course, and all has gone quite well so far.

however, when i get to the notify team section, add the discord node and configure it to display my unique id; selecting it from the http request header like this per the docs:
My Unique ID:
{{$node["HTTP Request"].parameter["headerParametersUi"]["parameter"][0]["value"]}}

it gets the correct unique id, however it’s prepended with a ‘=’ character in the preview.

drilling thru the Variable Inspector manually also shows the unique id as beginning with a “=” character although the other items simply show their value with no prepended ‘=’.

  • so, say my unique id is: xxxxxx, it is showing as =xxxxxx.

as a result the workflow & node are both running successfully, but nothing is being posted to the server channel course-level-1.

existing entries in the channel don’t show the leading ‘=’ character.

i was able to successfully post the webhook by entering my unique id manually in the discord node’s text string :partying_face: but it seems i should be able to use
{{$node["HTTP Request"].parameter["headerParametersUi"]["parameter"][0]["value"]}} successfully, no?

what do i need to do to strip the nasty = from the result?

Hm, I went through the course a while back but don’t remember this particular problem. Have you by any chance created an expression in the unique_id header field of your HTTP Request node?

If so, could you try resetting the field by clicking the little gears icon next to the field and then Reset Value?

1 Like

yup, that was exactly the case. being i think the second node i’d encountered, i somehow managed to add the header value by adding an expression containing the correct value.

i’ve since reset the value of the field, entered the unique_id properly and removed my hard coded value from the discord node and have confirmed it now works as expected.

thanks so much for the assistance. i’m just getting up to speed here :slight_smile:



1 Like