BigQuery POST issue

Hi n8n team,

I discovered your tool 1 week ago, and after an installation on a Debian VM hosted by Google Cloud (I never used linux before), i’m starting to play with nodes !

I used Google BigQuery as datawarehouse and I want to create a new table.
The BigQuery node cannot do it so i’m using HTTP nodes with Oauth2 auth.

Describe the problem/error/question

When I’m using a POST request to create a new table I’ve the following issue

ERROR: UNKNOWN ERROR - check the detailed error for more information
Request failed with status code 400

NodeApiError: UNKNOWN ERROR - check the detailed error for more information
    at Object.execute (/usr/lib/node_modules/n8n/node_modules/n8n-nodes-base/nodes/HttpRequest/V3/HttpRequestV3.node.ts:1313:12)
    at processTicksAndRejections (node:internal/process/task_queues:95:5)
    at Workflow.runNode (/usr/lib/node_modules/n8n/node_modules/n8n-workflow/src/Workflow.ts:1261:19)
    at /usr/lib/node_modules/n8n/node_modules/n8n-core/src/WorkflowExecute.ts:949:29

I copied the Curl request from Google API Explorer and just change the credential (in order to limit body issues)

When I try a GET through http request node it’s OK no error.

I tried to log issue through n8n log file but I do not have more information.

Please share your workflow

For now, I don’t use transformation.

Information on your n8n setup

  • n8n version: 0.222.2
  • Database (default: SQLite): default
  • n8n EXECUTIONS_PROCESS setting (default: own, main): default
  • Running n8n via (Docker, npm, n8n cloud, desktop app): npm
  • Operating system: debian-11-bullseye-v20221206

Thank you in advance for your help

Hi @Ponof, welcome to the community!

We’re about to release a big overhaul of the Bigquery node that will fix this, but in the mean time here’s an example HTTP node configuration for creating a table that works for us. Note that you’ll probably need to delete/change the location parameter.

1 Like

Hi @sirdavidoff, thank you for your quick answer.
Unfortunately I’ve still the same issue.
Maybe I do not use properly the query value.

Do you know when the release will be done?

It’s being reviewed now, so hopefully should be out next week or the week after.

Are you able to share your create table SQL? Have you tried with something really simple like SELECT 1?

Hello, even the simple request is not good (same node.js error).
I could wait two weeks to see if new version solve the issue.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.