Brandfetch Support v2

The idea is:

The brandfetch API currently only supports the v1 API which means newer users are unable to use the current node.

The node needs to be updated to support v2 which will work for existing and new Brandfetch users.

Any resources to support this?