Bug: After update no details of executions anymore

Hey,
I freshly updated to 0.209.4 and a few minutes ago even to 0.210.2.
I didn’t update my n8n docker image (using MacOS Docker Desktop) for a longer time (I had to do it manually and the previous one is probably a few months old).
My database is sqlite, just to test (and also because my database was over 2gb big), I truncated the executions table once, if this could fix the issue.

The only error message I see is this one:

2023-01-09 18:50:09 n8n-traefik-1  | time="2023-01-09T17:50:09Z" level=info msg="Configuration loaded from flags."
2023-01-09 18:50:09 n8n-traefik-1  | time="2023-01-09T17:50:09Z" level=error msg="The ACME resolver \"mytlschallenge\" is skipped from the resolvers list because: unable to get ACME account: permissions 644 for /letsencrypt/acme.json are too open, please use 600"
2023-01-09 18:50:09 n8n-traefik-1  | time="2023-01-09T17:50:09Z" level=error msg="the router [email protected] uses a non-existent resolver: mytlschallenge"


the executions-current endpoint returns an empty data object, the executions you can see in the screenshot, i tested also with the chrome browser. The spinner is spinning around forever.

I know this problem should have been resolved regarding this topic: BUG: After update can't see executions anymore - #11 by milorad
But sadly the update didn’t work for me.

Thank you for any help

Hey @FirePanther
looking at your browser console, looks like your browser is refusing to show execution preview iframe because X-Frame-Options header is set to Deny, which looks to me like a coulprit for this issue.
How are you running n8n? I see you mentioned that you are using Mac Docker desktop but can you give us any more info (docker command you are using, any additional server config) so we can try reproducing the issue?
One more thing: Can you try opening a template preview (like the one in the screenshot below) and see if it loads correctly?

1 Like

Oh man, @milorad, thank you, this was the reason!
I have a reverse proxy, I didn’t even know I’ve added this header. After changing to SAMEORIGIN it worked!
Thanks a lot

1 Like

Alright! Glad this was so straightforward to resolve :slightly_smiling_face:
Could be that it is the default value for the proxy you are using so you weren’t aware of it.

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.