Bug - Can't use N8N at all

Describe the problem/error/question

Hi everyone, can’t use N8N at all, it simply doesn’t work the screen is blank, console is full or errors and I don’t see any element of interface (using the web version). I’ve tried on Chrome, Brave and Firefox, same results unfortunately. Any help or ideas?

PS: The automated bot wants me to fill in some irrelevant information so here you go:

  • n8n version: Online version
  • Database (default: SQLite): Don’t know, web version
  • n8n EXECUTIONS_PROCESS setting (default: own, main): Don’t know, web version
  • Running n8n via (Docker, npm, n8n cloud, desktop app): I guess n8n cloud
  • Operating system: Mac OS although technically I suppose it’s irrelevant as it’s not me who is hosting the solution

What is the error message (if any)?

An example of what I (don’t) see on my screen:

An example of what I see in the console:

Any ideas are welcome, we would like to switch from Zapier to N8N but obviously can’t make the jump if it doesn’t work for us :wink:

It looks like your topic is missing some important information. Could you provide the following if applicable.

  • n8n version:
  • Database (default: SQLite):
  • n8n EXECUTIONS_PROCESS setting (default: own, main):
  • Running n8n via (Docker, npm, n8n cloud, desktop app):
  • Operating system:

This looks like some browser extension is messing with the JS code.
Those React errors in Button.jsx aren’t from n8n, since n8n doesn’t use React.

The error about this.templatesStore being undefined is an issue in n8n, but it’s possible that this is also being caused by an extension.

Can you please try another browser and let us know if that fixes the issue?

Also, can you please try going to the /workflow/new page, create a workflow, and then see if that fixes this issue n other pages as well?
:pray:

Thanks for your answer, this is a brand new Firefox install so no extensions are there and as specified above I’ve also tried this on Brave and Chrome so that would be weird that we have the issue on all three browsers wouldn’t it?

can’t do that, don’t see anything on the screen no element of interface are visible

Just looked at my firefox extensions and can confirm there is none active.

We are able to reproduce this and are working on fixing it.
In the meanwhile, can you please go directly to the new workflow page and save a workflow?
Once there is at least one saved workflow, the issue disappears.

4 Likes

Hi @Fab our sincere apologies that you encountered this issue. This issue is currently impacting new users who have no workflows, as @netroy mentioned. Work is being done to address it (some of which you can see here: fix: Fix empty page for Sales Cloud users by mutdmour · Pull Request #9700 · n8n-io/n8n · GitHub) and there will most likely be a patch fix for this issue released soon.

Thank you for being a part of the community and reporting this when you saw it!

1 Like

No worries, thanks a lot for responding so quickly :pray:

1 Like

Hey Fab, thanks so much for your report. We should have the issue fixed very soon. In the meantime, you should be able to change your URL in your browser from /home/workflows to /workflow/new. This should bring you to an empty canvas. If you save that now, the bug should be gone. Can you confirm that?

It does work indeed, thanks a lot :pray:

1 Like

Hi @Fab, thanks for your patience. Version 1.44.2 has just been released as stable and should resolve the issue you encountered. Happy building!

2 Likes

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.