Bug Node OpenAI Assistant : tool "query" formatting

The OpenAI Assistant node does not allow for French or other special characters when using tools :

[
{
"query": "Votre derni�re r�daction n'�tait pas conforme aux instructions, car elle incluait <span class="bold">la cr�ation de contenu non demand�</span>. Il �tait demand� uniquement l'<span class="bold">optimisation de sections sp�cifiques</span> du texte existant."
}
]

Could it be possible to change the encoding to utf8 or handle the cases ?

It looks like your topic is missing some important information. Could you provide the following if applicable.

  • n8n version:
  • Database (default: SQLite):
  • n8n EXECUTIONS_PROCESS setting (default: own, main):
  • Running n8n via (Docker, npm, n8n cloud, desktop app):
  • Operating system:

v 1.26.0, cloud

Hi @Lester_Reynolds :wave: Thanks for posting what version of n8n you’re on!

It might be best for @oleg to confirm when he’s back, but I don’t believe that there’s the ability to set UTF8 encoding :thinking:

I just tried this with the chat assistant and a calculation, which was able to parse non-latin characters just fine. Could you provide perhaps some example JSON of what you’re sending to the AI assistant? Is it only this specific tool that’s encountering the error, or is it others?

The assistant can parse specials chars no problem, except when creating the query to use a tool.

No tool worked for me. I can see that the query that is sent does not contain proper encoding

Okay it turns out that the problem came from GPT4, and was fixed in today’s release !

2 Likes

Hi @Lester_Reynolds - glad that this was fixed up with the new release! :raised_hands:

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.