Bug node selection does not work

I’ve updated to 0.222.3 a few days ago, and now I cannot select multiple nodes any more with the selector. ( I do not know how to call it, when selecting multiple nodes at once with the mouse wihtout clicking on each node)
Is that a known bug for that version?

Information on your n8n setup

  • n8n version: 0.222.3
  • Database (default: SQLite): MySQL
  • n8n EXECUTIONS_PROCESS setting (default: own, main):
  • Running n8n via (Docker, npm, n8n cloud, desktop app): Docker
  • Operating system: Ubuntu
1 Like

Hi @FelixL, I am sorry for the trouble. This sounds like you might have encountered this bug. Can you verify whether this still happens for you on [email protected]?

Hi @MutedJam,

there are some similarities between the bug report and my issues, but for me the selection does not work at all.

I’ve updated a test instance and the problem persists.

But a similar bug got fixed in 0.225.1:
From the github issue you linked:

also node connection (after “middle mouse move”) is a bit broken in a same way - when user start moving end point whole view also moves.

Hm, that’s odd. I am too using an Ubuntu-based OS and am not having any trouble with selecting nodes over here. I can still draw my rectangle as expected:

Tested this on both Chrome and Firefox. Is this just happening in specific browsers for you?

I’ve added a small screen recording to the bug on GitHub, hope that’s ok as I cannot upload videos here.

I am on Firefox on Windows 11, will try on other browsers too.

1 Like

I’ve tried on chrome and edgebeta too, same issue.

n8n is hosted on Unraid in this case.

Are there any logs i can upload to help with this case?
The Console in the browser does not show any errors.

Are you using the middle mouse button as well? If you are not using it then you may have a different issue.

Does your machine have a touchscreen as well?

I have not used the middle mouse click in the recording.

Yep the Laptop has a Touchscreen, but it was not enabled since the lid is closed.
I’ll try it on a Laptop without a Touchscreen.

Hey @FelixL,

Perfect so it is probably unrelated to the github issue and more than likely to be related to the touchscreen. Even though the lid is closed it is still there and that can sometimes cause issues, If it works on a laptop without the touchscreen we will know if that is the case.

Yep, you’re right, a Laptop without the touchscreen does not have the same problem.

I’ve also tried on another Laptop with a touchscreen and selecting also did not work.


I have created N8N-6338 as the internal ticket for this one.


This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.