Bug: OneDrive/Get Children: more then 200

Hey guys,

i have a bug for you :wink:

Describe the error

If you try to get all children with the “OneDrive Node” from a large folder (more then 200 elements) you get an error. This bug should already exist since version < ~0.130.0. I think it still worked in ~0.122.0

What is the error message?

[HTTP Status-Code: 400] Query option ‘$top’ was specified more than once, but it must be specified at most once.

Information on your n8n setup

  • n8n version: 0.158.0
  • Database you’re using: SQLite and MySQL
  • Running n8n with the execution process: own(default)
  • Running n8n via: npm

Hi @BillAlex, welcome back!

I’m sorry to hear you’re running into this problem and managed to also confirm this for the latest n8n release 0.159.1 :frowning:

From taking a very first look it seems we set this parameter in our first API request, but would add it again if Microsoft includes it in the “next page” link.

I’ll see if I can make this work and will post an update as soon as I get to it.

Okay, this should make it work :slight_smile:


Will let you know once it’s released!


This is why I love n8n :fire: Such a fast action.


I can only agree with @mcnaveen. Thanks @MutedJam for the quick bug fix!

For me, however, new problems arise - but then that is no longer a bug. That also does not need to be solved by n8n. I will find a solution.

There are over 25,000 items in my folder - and it’s getting more and more. No one needs that, only a machine needs it. After 60 minutes, I put n8n out of its misery and canceled the process.

I would wish for the OneDrive Node that you can optionally set the queries manually. This would allow you to set the OData options yourself.

Thanks again for the quick solution - works great (with “small” folders).


Many thanks for your feedback! I think allowing custom queries for power users would be a great feature request so you might want to raise this as such and let other users have their say :slight_smile:

Above fix got released with [email protected]