[Bug] Supabase Get Rows is limited to 1,000

Describe the problem/error/question

When I try to get up to 50K rows from my database (here the database is Supabase) then I get only 1K. Same when I select the option for “All rows”. My database has ~6K rows.

What is the error message (if any)?

Please share your workflow

(Select the nodes on your canvas and use the keyboard shortcuts CMD+C/CTRL+C and CMD+V/CTRL+V to copy and paste the workflow.)

Share the output returned by the last node

Information on your n8n setup

  • n8n version: ai-beta
  • Database (default: SQLite): default
  • n8n EXECUTIONS_PROCESS setting (default: own, main):
  • Running n8n via (Docker, npm, n8n cloud, desktop app): cloud
  • Operating system:

Hi @Kevin_Lourd, I am very sorry you’re having trouble. I was able to reproduce the problem and shall add it to our bug tracker for a closer look and a fix.

In the meantime, perhaps you want to query your Supabase data through the Postgres node (as described over here in more detail)? I just gave this a go and the Postgres node would fetch rows beyond the first 1,000 as expected:

We’ll of course update this thread once the Supabase node is fixed as well.

2 Likes

New version [email protected] got released which includes the GitHub PR 8311.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.