Can't change flows version to v1 by HTTP-Request

I have a flow, that updates other flows, but I need to update it to version 1 (recommended) by using HTTP-Request. According to API reference, “settings” field should have all setting i want to set. So I write “settings” field like this:

{{ { “saveExecutionProgress”: true,
“saveManualExecutions”: true,
“saveDataErrorExecution”: “all”,
“saveDataSuccessExecution”: “all”,
“executionTimeout”: 200,
“callerPolicy”: “workflowsFromSameOwner”,
“executionOrder”: “v1”
}
}}

In the end, I have an Error like this:

ERROR: Bad request - please check your parameters

400 - “{"message":"request.body.settings should NOT have additional properties, request.body.settings should NOT have additional properties"}” - {“message”:“request.body.settings should NOT have additional properties, request.body.settings should NOT have additional properties”}

==================
I really don’t know how to solve this problem, so I want to ask your help with this

Information on your n8n setup

  • n8n version: 1.0
  • Database (default: SQLite): PostgreSQL
  • n8n EXECUTIONS_PROCESS setting (default: own, main):
  • Running n8n via (Docker, npm, n8n cloud, desktop app): Docker
  • Operating system: Linux

Workflow with new parameters:

With Old:

Or if you have other ways to solve this problem, please help)

Hi @nsd6803 :wave: Welcome to the community! :tada:

At the moment, it looks like execution order isn’t supported via the API: How to handle Settings in N8N API Update Workflow

You might want to add in your use-case and upvote that feature request :+1:

1 Like

Thank you so much! Look forward for adding this feature asap)

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.