Can't pass along info from past nodes anymore

Describe the problem/error/question

I’m trying to pass along information from past nodes to respond to a webhook, or even just forward as a webhook somewhere else

What is the error message (if any)?

[invalid syntax]“] }}
[invalid syntax]”] }}

Please share your workflow

Share the output returned by the last node

“={\n "Response": {\n "Subject":"SUBJECT",\n "Message":"MESSAGE"\n }\n}\n\n{{ $json["customField"]["{{ $json.customFields[1].id }}"] }}\n{{ $(‘Fix subject for errors’).item.json["customField"]["{{ $json.customFields[1].id }}"] }}\n”

Information on your n8n setup

  • n8n version: 1.9.2
  • Database (default: SQLite): Default database in docker image
  • n8n EXECUTIONS_PROCESS setting (default: own, main): Unknown
  • Running n8n via (Docker, npm, n8n cloud, desktop app): Docker
  • Operating system: Linux/Cyberpanel/Docker

p.s. this used to work just perfectly fine on version 0.241

Hi @bonelli :wave:

It’s a little difficult without having some JSON as an example, but I can probably point you in the right direction :slight_smile: In your code nodes, instead of:

$node['Spintax Content'].json.parsed_string;
You’d need something like:
$('Spintax Content').item.json.parsed_string

If you fix this up for any time you’re calling a node, that should also fix up the error :bowing_man:

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.