Can't select nodes with the mouse - Moves the whole canvas

I’m on the latest n8n version: 1.26.0 - Installed through docker compose / traefik on a DO droplet.

Issue: using the mouse to select nodes moves the whole canvas. I’ve tried Chrome, opera, and Firefox and the issue persists.

What am I missing here? Is there some setting?

It looks like your topic is missing some important information. Could you provide the following if applicable.

  • n8n version:
  • Database (default: SQLite):
  • n8n EXECUTIONS_PROCESS setting (default: own, main):
  • Running n8n via (Docker, npm, n8n cloud, desktop app):
  • Operating system:

Hey @lexgabrees,

Are you using a device with a touch screen?

No touch screen here … just a regular monitor …

That is unexpected, It is working ok here and I know some laptops with touch screens can cause an issue even if you are not using that screen.

Are you using a special keyboard or mouse, Anything that may change the input or possibly change a key state?

Hey Jon, the scenario is as follows:

  • Dell XPS laptop with touch, but touch is switched off in the BIOS.
  • Issue persists if 2 external screens are removed.
  • I’m using a wired keyboard. (The issue persists if I use the laptop keyboard)
  • Bluetooth mouse (issue persists with Bluetooth off)
  • Deinstalled Wacom pen driver (so that’s not it).

All the browsers have the issue. So, I['m thinking it must still be something at my end … The question is what …

Will try another laptop in a bit and report back if something changes …

Well… same on another laptop, so it must be something to do with my Droplet. The strange thing is that I’ve used n8n on the same droplet a while ago (a month or 2) and there was no issue …

Hey @lexgabrees,

Did the other laptop also have a touchscreen even it iwas disabled? I have seen some devices still think the screen is on when it is disabled so it is possibly still the issue. We don’t have a config option in n8n for what you are seeing so it seems unlikely to be an issue with the droplet and more likely to be something with the hardware and a recent n8n release.

1 Like

So, it doesn’t matter to switch off touch in the BIOS … It works when I switch of HID in device manager …

Hey @lexgabrees,

Did that sort it out? I have seen some odd things with touch devices recently to me if it is disabled in bios it should be disabled properly but sometimes Windows (and some Linux distros) still think it is there and being used even though you can’t interact with it.

Yes … that sorted it out … It needs to be disabled from the device manager.

What can I say … at least the issue is clear now …

1 Like

I take it the second laptop was the same sort of set up?

Actually yes … It was touch as well, but running on a different version of windows, and much older. I figured maybe the difference in driver versions could shed some light on the problem, but it didn’t.

But since n8n used to work in the past without any issues … it could be something on either side …

1 Like

Hey @lexgabrees,

I suspect it is a change on our side although we do occasionally get these issues.

I have created an internal ticket to get this fixed soon though.

Could you let us know when this issue will be fix please ?

Thank again for all your works.

Hey @Kent1,

Will do, I have linked this thread and the other one to the dev ticket so both should get updated when this is fixed.

2 Likes

I’m having this problem as well, though I’m using your cloud version.

Hey @jamescv,

Welcome to the community :raised_hands:

Are you also using a device with a touch screen?

I didn’t think that applied to me. But now that you ask, I realised I don’t know for sure. It’s a Microsoft Surface 4 which I use with an external monitor and the lid closed. I’ll check if it’s touch screen when I’m using it again on Monday. And if it is I’ll follow the what Lex did in his screenshot.

Hey @jamescv,

I believe all MS Surface devices have a touch screen so the good news is this still seems to be specific to touch screen devices.

image
So I’ve disabled the ‘Surface Touch Screen Device’ and it doesn’t seem to have fixed the issue.
You made comments earlier on about special keyboards and mouse that might change the input or a key state. Could you elaborate on this please? I am using a logi mouse that allows me to configure the buttons for different applications, so I wonder if it might be impacting.
(That said I have the same mouse/keyboard combo on my desktop and it seems to work fine).