Changes with Notion credentials / setup? Can't add n8n via "Share"

I’m trying to create a workflow with Notion, following the directions at Notion - n8n Documentation

The connection with the API key in n8n says it’s successful. The integration page in Notion shows the n8n integration has full permissions to everything within my workspace.

However, I’m not able to add my n8n integration to any of my Notion databases / pages. When I click the “Share” dropdown, n8n is not an option. Since I can’t add n8n to any Notion databases, attempting to use to any of them in a workflow results in a 404.

The n8n integration is not showing as a connection in “Settings & Members” —> “Connections,” but is showing up under “Settings & Members” —> “Workspace” —> “Connections.” Perhaps that’s expected, but I thought I’d mention it in case:


All the other integrations that are showing in either of these screenshots, along with n8n, are connecting and working properly.

I read here that some people found the Notion API to take a while to work, it’s been about 24 hours. Is it supposed to take longer than that? Anything I’m missing or could try?

Thank you.

Hi @mmac, it seems you are right. I just checked my own Notion account, and it seems a page can now be shared with an integration via ...Add connections$custom integration name on the respective page.

Perhaps you can give this a go on your side?

Managing integrations and their secrets still works via the page at https://www.notion.so/my-integrations for me.

Perfect, I found it under “Add connections.” I’m a little embarrassed I missed that option!

And yes, the https://www.notion.so/my-integrations has been fine for me as well. I just couldn’t find how to add n8n to a page after having created the n8n integration, since that option moved from “Share” to “Add connections.”

Thank you!

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.