Clickup timeout

How to solve the problem with timeouts? It occurs with relatively small amounts of data.

@maxbaluev seems like the ClickUp rate limit is 100 requests per minute. How many inputs are the ClickUp1 node getting? Keep in mind that the delete operation will execute as many times as input items it gets. If you share the whole workflow, I can help you better.

It gets a lot, I write to the file and run cron batches of 50 pieces. Timeout already crashes at 50+ writes (multiple actions).

If there was a timeout property in the clickip node - it would greatly simplify the logic and you could just put a timeout on every request, even for 10000+ elements.

Right off the top of my head and with the current info you have provided, I would say you have two options here.

1 - Use the HTTP node with the options Batch Interval and Batch Size.
2 - Use the SplitBatches node and create a “wait” with the function node.