Cloud hosted workflow editor only shows blank space

I just started the free trial of n8n cloud and I can’t open the editor in projects. I have a limit of 1 project and as soon as I create one and then go the workflow tab it turns blank and I can’t interact with the project in anyway unless I go back a page in the browser. I tried restarting safari, use chrome, restarting my laptop and creating a new account. What else can I do to make it work?

n8n version: 1.44.1
Running n8n via: n8n cloud
Operating system: macOS Sonoma 14.5

Thanks in advance

It looks like your topic is missing some important information. Could you provide the following if applicable.

  • n8n version:
  • Database (default: SQLite):
  • n8n EXECUTIONS_PROCESS setting (default: own, main):
  • Running n8n via (Docker, npm, n8n cloud, desktop app):
  • Operating system:

Hi @Jonasdba ,

Welcome to the community! :sparkles:

I can’t seem to replicate the issue. I have a trial account on the same version and it’s working fine in chrome and firefox at least.

Would you be able to show your steps and maybe add some print screens of what you get?

If you want you can also send me your instance username in a private message and I can see if there are any hints attached to your account in particular, although I have little hopes there



Thanks for the reply! I’ve attached the printed webpage and a screenshot.

I don’t know if I tagged you correctly, so the message above is meant for you @mariana-na

Hi @Jonasdba ,

Thanks for sharing the images!
Are you able to interact with the platform at all after going back a page?

If you haven’t already, I would suggest clearing your browsers cache, desabling browser extensions and see if that helps.
If that doesn’t help, I can delete your account and free up your email and username to sign up again and get a new trial

Hi @mariana-na ,

Thanks for the reply! I am able to interact with the platform via the sidebar, without needing to go back a page. Only the project space is blank. When I implement templates I can also see and interact with them in the home area.

I tried deleting all my browser data and deactivated my extensions (even restarted my macbook again). I already tried to sign up again (I currently have two free accounts), but it still didn’t work. We can try again, but then I would ask you to delete both accounts.

Thanks for trying that!

This stemed from a bug we had that affected new cloud users. Our team is already working on this and the fix should come in soon.

In the meanwhile, if you could create a new workflow, this should workaround the issue and allow you to get a normal view again.

You can do it by changing the URL in your browser from /home/workflows to /workflow/new.
So, it would look like this: https://[username].app.n8n.cloud/workflow/new

Please let me know if this fixes it

Hi @Jonasdba,

Thanks for your patience on this!

Version 1.44.2 has just been released as stable and should resolve this issue :tada: