Course 1 - Hacker News node not working

Hello, I’m just starting the course, and I followed the first step, but when I execute de hacker News node, I get an error : ERROR: UNKNOWN ERROR - check the detailed error for more information
and when I check further I get this for the “http-code” : UNABLE_TO_GET_ISSUER_CERT_LOCALLY
and this as a message : Error: unable to get local issuer certificate
I just followed the course and don’t really know what i could have done wrong.
I’m using n8n with docker, because i can’t open the n8n.cloud on my network (i’m an intern)
thanks for any help

Hey @amauryMltr,

Welcome to the community :sparkling_heart:

Can you share the command you used to start the n8n instance? I tested out the node both on a Docker instance and on n8n.cloud, and it works as expected.

I’m using Docker Desktop, so I just have a run button to start it, but i don’t have a lot of knowledge in docker neither

Just noticed you said you can’t use n8n cloud as you are an intern, That bit of information with your error makes me think there is probably a proxy / web filter getting in your way.

Do you get an error when you open your browser and go to: https://news.ycombinator.com/

Hello, thanks for the idea, but sadly i can open this link without any problem

Hey @amauryMltr,

Can you try using a request to a URL using the HTTP Request node?

I used the http request node with the url : https://www.poemist.com/api/v1/randompoems and it worked
But it was part of a workflow I created at home on my network and from memory it was working, I used the same http request as mentioned above, then the LingvaNex node to translate it, and now the LingvaNex has the same error as the HackerNews node, … so it’s probably related to my network :frowning:

@amauryMltr What I think is happening is you have a proxy / filter (like zscaler) doing content inspection which is swapping out the certificate with a local self signed one and as it isn’t matching you are getting some errors.

From your machine it is probably fine as you can reach the internal CA but the docker container might not be able to, You could have a chat with your internal IT team and see what they can suggest.

If you happen to have the PEM what you can do is add NODE_EXTRA_CA_CERTS to your environment options for the container and that will allow it to work, In theory you might be able to use a command node and throw in npm config set strict-ssl false to see if it changes but I would be careful as it turns off the certificate checking.

1 Like