Cron being ignored flows keep running

ive recently moved from beta-ai to n8n:latest.

I have got over the secure cookie false issue I had. and can log in again now.

However, a new issue has arisen for me. Cron seems to be ignored, and the flows are just running in a loop. I don’t know how to stop it, im killing executions and they just come back again. So I’ve had to turn n8n off.

Any thoughts?

It looks like your topic is missing some important information. Could you provide the following if applicable.

  • n8n version:
  • Database (default: SQLite):
  • n8n EXECUTIONS_PROCESS setting (default: own, main):
  • Running n8n via (Docker, npm, n8n cloud, desktop app):
  • Operating system:

Where are you hosted and what’s your version?

Do you mean that the workflow with a schedule trigger is just being constantly triggered?

Are you above 1.29? There was a bug in the wait node that was patched in that release, but I don’t know if the trigger was effected by that bug

Check:

  1. That your timezone is set correctly in the workflow settings found here

  2. If it was correct, then try changing the timezone to UTC and inputing everything in UTC time.

If that doesn’t work then please share your workflow so that we can see the settings of the trigger node as well as the context of the surrounding nodes

1 Like

Self hosted. Using the latest version pushed by docker.

The timezones are all correct.
As soon as docker boots it just tries to run all the flows over and over. There is no error in the console

You can try to disable all workflows via the command

n8n update:workflow --all --active=false

And then check if something wrong with the workflows/nodes

ok will have a look at that thanks.

weird as these flows have been running for a very long time, only since moving away from beta and to latest something isnt quite right