Customized UI not reflecting on production mode(npm start). Working fine with dev(npm run dev)

Hi,

My customized UI is not reflecting in production mode, and working fine with Dev mode.
I had edited editor-ui but after npm start, showing default UI only.
I tried with npm run build. did clean everything but still facing the same.
Could someone please help me…
Thanks in advance…

Hey @Jaimish_Golakiya!

Welcome to the community :sparkling_heart:

Do you the code on GitHub that we can try running? If you’re seeing the changes in the dev env, then you should be able to see the changes in the production env as well.

Hi @harshil1712!
Thanks for the quick response
https://drive.google.com/file/d/1iRUCdixrsF0x7kuunRRd3vpEhA7KZn3s/view?usp=sharing

Here is editor-ui folder which I had customized. you can just replace it with default and try…

Thanks you so much…

5678 VS 8080


Hey @Jaimish_Golakiya,

We tested it out and the builds fail. Can you please pull the recent changes from GitHub and try building it again?

I am also curious to know about the reason of customising the UI! Can you please share some insights?

@harshil1712 , I have checked with n8n latest master but still facing the same.
You just try to remove n8n logo on n8n/packages/editor-ui/src/components/MainSidebar.vue,
comment line number 16 to 21.
and rebuild the project.
you will see that change in dev(npm run dev) and not in the prod(npm start)…

trying for 2 days to resolve this issue.

Thanks for your input @harshil1712

Hey @Jaimish_Golakiya,

I followed the steps you mentioned, commented out the code from lines 16 to 21 in the n8n/packages/editor-ui/src/components/MainSidebar.vue file. I ran npm run build and then npm start. I got the expected result.

Do you get any errors during build?

I was getting the errors but I did below things after that was able to
Installed below thing
n8n/packages/node-dev/
npm i --save-dev @types/request
npm i --save-dev @types/request-promise-native

then n8n/packages/nodes-base/
npm i bson

Could you please share your code zip file and share the steps of how you are starting the n8n?
that will be helpfull.

Hey @Jaimish_Golakiya,

Here are the steps that I took:

  1. Clone the GitHub repo
  2. Comment out the code.
  3. Run lerna bootstrap --hoist to install the packages (from the root n8n directory)
  4. Run npm run build.
  5. Run npm run start

There isn’t a lot of changes that I’ve made, except for commenting the lines from 16 to 21.

1 Like

I was doing manually npm install everywhere instead of lerna bootstrap --hoist

Thanks you so much for your quick support. Love the way you’re supporting.

1 Like