Date weirdness: when retrieving a date (from mysql) the date cannot be used in following nodes expression

Hi There,

We are having a strange issue. It was also mentioned in another topic but the poster marked it as resolved. https://community.n8n.io/t/global-execution-dont-give-same-output-than-execusion-node-by-node/21852
We cannot use a date calc on a timestamp returned from MySQL, it does run when you run the node itself and is all good. But when running the complete workflow it does not return any value.
This also is the case for the split function etc. It seems like the field simply does not exist when running the workflow (manually & scheduled tested).

Not working with data from MySQL:


Working with copied timestamp string:
image

workflow:

Update
So I tried what the other poster did. This did fix it for the normal execution but broke it for the manual execution of the node itself.

So there is something weird going on with the Date, as it is shown as a string. and works as a string when running the node itself.
But then when running the workflow n8n already understands it is a date and treats it as such.
I think it is nice that the date is automatically recognized, but developing workflows like this is really annoying.

Also, the new Schema shows it as a string, which would be nice to have it tell us it is recognized as a date maybe.

Information on your n8n setup

  • n8n version: 0.209.4 & 0.210.2
  • Database you’re using (default: SQLite): Postgres & n8n Cloud
  • Running n8n with the execution process [own(default), main]: main & n8n Cloud
  • Running n8n via [Docker, npm, n8n.cloud, desktop app]: Docker & n8n.cloud

Hey @BramKn,

I have created N8N-5966 as an internal ticket to look into this further.

1 Like