DNS Error when using HTTP Request Node

I’m using the HTTP request node and get this error:

ERROR: The DNS server returned an error, perhaps the server is offline

getaddrinfo EAI_AGAIN video.bunnycdn.com

  • I’ve tried pinging the URL and it returns a correct response
  • I’ve tried sending a test Post Request via Bunny’s site and that returns a 200 response

I’m using the online version of n8n.

Any ideas?

Thanks

Hey @Vanja,

Have you tried adding the retry option to your nodes settings? Sometimes the EAI_AGAIN is just temporary.

Hey @Jon

Just tried it with a couple of different wait times. No cigar i’m afraid

Thanks

Do other http requests fail?

No others work fine

That is very odd I would have expected DNS to impact other sites as well, I wonder if we just can’t connect for some reason.

Can you share a test URL?

is this what you’re after (the libraryID is for my account number)

https://video.bunnycdn.com/library/{libraryId}/videos

Got this from Bunny support:

Can you please check if our IPs are whitelisted on the origin? There’s a chance the connection to video.bunnycdn.com is not happening because our IPs are blocked:

https://bunnycdn.com/api/system/edgeserverlist/

https://bunnycdn.com/api/system/edgeserverlist/ipv6

@Jon any update on this? Are you guys looking for a fix or should I look for alternative solutions? Need to get this project moving and this is holding things up right now! Appreciate it

Hey @Vanja,

I have been looking into it between other issues, I have managed to reproduce it on n8n cloud but not when using a self hosted instance so it does look like something is being blocked somewhere.

From what I understand we don’t block anything on Cloud, I still need to raise an internal ticket to have that looked into but from an application view everything looks great so it could be that we are blocking them or maybe they don’t like something we are sending.

Can you send me a DM with your cloud username in it?

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.