Docker compose n8n main instance + n8n worker (queue mode) job are not started in my logs

Docker compose n8n main instance + n8n worker (queue mode) job are not started in my logs

When I go to “Settings/Workers” → in my logs I see this error :

TypeError: Cannot read properties of undefined (reading ‘publishToWorkerChannel’)

And I followed this article :

But by following everything the exact same way I dont see my workers.

I have a licence activation which I can activate but when I go to the workers page I keep seeing a progress bar and also the api call (/settings/workers) keeps telling me :

We’re sorry but the n8n Editor-UI doesn’t work properly without JavaScript enabled. Please enable it to continue.

And I found no simple tutorial explaining me how to activate JS in n8n, I found one but again in the documentation you say to try some commands but when you reach to the point of the “npm i n8n-community-nodeName” it says the package does not exist..

I think a KISS (Keep it stupid simple) tutorial to have queue mode with a worker example could be nice because the link above is not a proper tutorial.

Like something with a docker-compose

What is the error message (if any)?

Please share your workflow

(Select the nodes on your canvas and use the keyboard shortcuts CMD+C/CTRL+C and CMD+V/CTRL+V to copy and paste the workflow.)

Share the output returned by the last node

Information on your n8n setup

  • **n8n version: n8nio/n8n:1.36.1
  • **Database (default: SQLite): postgres
  • **n8n EXECUTIONS_PROCESS setting (default: own, main): own (self-hosted)
  • **Running n8n via (Docker, npm, n8n cloud, desktop app): Docker
  • **Operating system: Mac

Can you please try to update to the latest version and see if that fixes the issue?
if not, can you please then share your docker-compose file and any relevant information about your reverse-proxy?

It has been resolved everything is working now, it was because we needed to trigger the workflow through a production url not Test url