Docker-compose up fail for unexpected reson after upgrading from 0.159.1 to 0.169.0

Describe the issue/error/question

After following the suggested tutorial and install the lts version aka (0.169.0) I run docker-compose up
it start but display an error:

Creating network "n8n_dir_default" with the default driver
Creating n8n ... done
Attaching to n8n
n8n    | 
n8n    | 
n8n    | #
n8n    | # Fatal error in , line 0
n8n    | # unreachable code
n8n    | #
n8n    | #
n8n    | #
n8n    | #FailureMessage Object: 0x7eaa74ec
n8n exited with code 133
n8n exited with code 0
n8n exited with code 133

What is the error message (if any)?

n8n exited with code 133

Information on your n8n setup

  • n8n version: 0.159.1
  • Database you’re using (default: SQLite): SQlite
  • Running n8n with the execution process [own(default), main]:
  • Running n8n via [Docker, npm, n8n.cloud, desktop app]: docker-compose

Welcome to the community @dangerblack !

I can currently not explain this error. Is super strange. Have honestly never seen that before. What n8n version are you running (you somehow mention 0.159.1 and 0.169.0)? Do you really run the default n8n docker images (if so which exactly) as they are published without any changes? What operating system are you using? How does the docker-compose file look like?

I got the same problem. I created an issue on Github: Docker error after upgrading to 0.166 or above · Issue #3046 · n8n-io/n8n · GitHub

Version 0.166.0 is causing the problem. Probably by the switch to NodeJS version 16.
See this commit: 🐳 Update Node.js versions of Docker images to 16 · n8n-io/[email protected] · GitHub

Thanks Yoaz to link those issue, I was assuming that the problems comes from node version somehow.

Do you really run the default n8n docker images (if so which exactly) as they are published without any changes?

yes

What operating system are you using?

I’m on my raspberry pi

[email protected]:~ $ cat /etc/os-release
PRETTY_NAME="Raspbian GNU/Linux 10 (buster)"
NAME="Raspbian GNU/Linux"
VERSION_ID="10"
VERSION="10 (buster)"
VERSION_CODENAME=buster
ID=raspbian
ID_LIKE=debian
HOME_URL="http://www.raspbian.org/"
SUPPORT_URL="http://www.raspbian.org/RaspbianForums"
BUG_REPORT_URL="http://www.raspbian.org/RaspbianBugs"

How does the docker-compose file look like?

Is quite straightforward but I have some weird mount point that I removed to perform a clean test, and it doesn’t work anyways.

I got the same error and I also think the node 16 caused the problem.
So I only upgrade to 0.165.1 (lastest version of node 14), there is no problem.

1 Like

I have just given this a test on a Pi I have here and using a simple compose file 0.170.0 appears to be working fine, I am using Ubuntu Server 20.04 on my pi with Docker 20.10.12 and compose 1.25.0

docker-compose.yml
version: "3"

services:
  n8n:
    image: n8nio/n8n:latest
    restart: always
    ports:
      - "192.168.1.139:5678:5678"
    environment:
      - N8N_HOST=192.168.1.139
      - N8N_PORT=5678
      - N8N_PROTOCOL=http
      - NODE_ENV=production
      - GENERIC_TIMEZONE=Europe/London
      - TZ=Europe/London
      - EXECUTIONS_PROCESS=main
    volumes:
      - /root/n8n/.n8n:/home/node/.n8n

It would be handy to see the compose files you are all using and I can give them a test here to see if they work.

As CCninja86 commented on the GitHub issue will upgrading Docker help to solve that issue:

That could then also explain why it works for @jon.

1 Like

This is my docker compose

version: '3.3'
services:
    n8n:
        container_name: n8n
        ports:
            - '5678:5678'
        restart: always
        volumes:
            - '~/MoreDoc/n8n_dir/.n8n:/home/node/.n8n'
        image: 'n8nio/n8n:0.159.1'
        environment:
            - N8N_BASIC_AUTH_ACTIVE=true
            - N8N_BASIC_AUTH_USER=xxxxx
            - N8N_BASIC_AUTH_PASSWORD=xxxxxxx
            - EXECUTIONS_DATA_PRUNE=true
            - EXECUTIONS_DATA_MAX_AGE=120
            - EXECUTIONS_TIMEOUT=300
            - EXECUTIONS_TIMEOUT_MAX=500
            - GENERIC_TIMEZONE=Europe/Berlin
	    - DB_SQLITE_VACUUM_ON_STARTUP=true

Docker:

docker --version
Docker version 19.03.15, build 99e3ed8919

Docker compose:

docker-compose --version
docker-compose version 1.29.2, build unknown

Hey @dangerblack,

What version of libseccomp2 does Buster use? A quick look on the package site suggests it is 2.3.3-4, It looks like the backports repo has a newer version which lookign at the Github issue could be something else needed.

Is there also more to your compose file? The error output mentions a network being used that isn’t in your compose file which seems odd.

I would start with checking libseccomp2 anyway (apt list libseccomp2) to see what that is, For me it is 2.5.1-1. If I get a chance I can reflash my Pi to use Buster but I am not sure when I will be able to do that.

1 Like
apt-cache policy libseccomp2
libseccomp2:
  Installato: 2.3.3-4
  Candidato:  2.3.3-4
  Tabella versione:
 *** 2.3.3-4 500
        500 http://raspbian.raspberrypi.org/raspbian buster/main armhf Packages
        100 /var/lib/dpkg/status

Probably we found the cause

That could be it, So there is an updated version available in the buster backports source list so you could possibly add that do an update and see if it works.

I got it working by updating libseccomp2 (version 2.5.1-1~bpo10+1).
Docker was already up to date: 20.10.14.
I found an article which helped me: Fix/Workaround - libseccomp2 and Alpine 3.13 - Installing Raspbian Docker 19.04+ on Raspberry Pi 4 Buster

2 Likes

Thank you, it works!

1 Like