Docker image

hello @Jon !
what would be the latest n8n version where subfolder path is supported?
where i can confifure n8n to run under subdomain.domain.com/n8n? i couldn’t find this info the release notes…
Thank you in advance!

Hey @Nargiza_Fernandez,

It should be supported now as we have not dropped support for it so at some point another change has impacted it.

I would recommend using a subdomain for n8n until this is resolved.

1 Like

thank you for your response @Jon!

im still trying to achieve my goal. i have set up my deployment yaml where i specified env variables such as:
env:
- name: N8N_HOST
value:sub.domain.com
- name: N8N_PATH
value: /n8n/
- name: N8N_PROTOCOL
value: https
- name: NODE_ENV
value: production
- name: VUE_APP_PUBLIC_PATH
value: /n8n/
- name: N8N_EDITOR_BASE_URL
value: https://sub.domain.com/n8n/
- name: WEBHOOK_URL
value: https://sub.domain.com/n8n/
image: n8nio/n8n:1.3.1

but still no luck… here are screenshots with the output.


i tried to specify:
- name: N8N_BASIC_AUTH_ACTIVE
value: “true” # Enable Basic Authentication
- name: N8N_BASIC_AUTH_USER
value: xxxxxx
- name: N8N_BASIC_AUTH_PASSWORD
value: xxxxxx

which i knew wouldnt work, because it wasnt mentioned in docs, but i was hoping :smile:

i also tried using docker-compose as suggested in https://github.com/n8n-io/n8n/blob/master/docker/compose/subfolderWithSSL/docker-compose.yml , however, in my case it didnt work either…

is there anything else you could recommend?

thank you in advance!

Hey @Nargiza_Fernandez,

For now I would recommend using a sub domain although your 401 errors look to be authentication related so maybe there is a proxy setting that needs to be enabled as well.