Docker installation: high load

latest image f9d0a9e1924c

I try to run my workflow and it puts the container into high load.

# docker-compose logs -f

n8n-n8n-1       | The session "lm6npjtun8e" is not registered.
[ .. repeated ..]

Tried to disable some nodes in my workflow, restarted the stack, same result.

Tried with image n8nio/n8n:0.205.0: same result.

Maybe something has crashed in my setup. Maybe it’s some kind of bug. I just want to report this.

Hey @sgw,

When you say high load what do you mean?

@Jon The docker host revs up, and 2 or so processes use >90 % CPU …

@sgw what is the workflow doing? How much data is it loading? Does it happen with smaller workflows? How is the workflow being triggered?

It’s triggered by a Start-Node, so manually.

Start triggers a Set-Node, which sets a ID to a specific value (it’s a test still).

The amount of data is small:

it calls an API and fetches a ticket from Zammad (not using the Zammad node, but via HTTP request).

That ticket consists of 4 articles and 3 attachments … all these should be fetched via API calls.

The list of attachments gets “Split out” into 4 parts, and piped into another HTTP-Request that fetches these files.

That branch of the workflow is the one shown here: Zammad and Webhook - #12 by MutedJam

Update, maybe solved:

I had non-connected nodes inside of the workflow, basically left over from copying together various workflows and fitting parts of them together.

I cleaned up the workflow now, saved, currently it runs through OK.

Sorry for the noise, it maybe is an FAQ to keep the canvas clean.

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.