Docker Setup Question


My question is probably out of the realm of the typical support but I’m hoping someone may be able to help point me in the right direction. I’m fairly new to docker and openlitespeed. I’ve managed to get them both installed and running wordpress at a specific domain.

  1. I wanted to install n8n on the same server with a subdomain url. I got n8n installed and running at the subdomain although it’s displaying the port in the url. Does anyone know what I need to do get remove the port address from the url?

  2. Another issue I’m running into is I created a database in MariaDB for n8n but when I try to connect n8n to the database the connection in refused. But I can log directly into the database with the credentials that I’m providing n8n.

Any help would be greatly appreciated.

Hey @VanLuda,

Can you share your docker command? It sounds like your might just need to add the webhook_url env option.

With the database what error are you getting?

Alright, I figured out the database problem… I had something wrong in my docker-compose.yml file… :man_facepalming:

I’ve been reading about openlitespeed and virtual hosts. I think my problem is within the configuration in the openlitespeed UI.

@Jon I have the webhook_url in my config file and that looks correct. It’s the url were the app is coming up that is the issue. So I want it to be and it’s showing as in the url. I’m happy to share whatever you’d like.

Can you explain what you mean by the docker command? To start in the cli I’m using docker compose up. Then the it prints out:

www-n8n-1         | Initializing n8n process
www-n8n-1         | n8n ready on, port 5678
www-n8n-1         | Version: 0.202.1
www-n8n-1         | 
www-n8n-1         | Editor is now accessible via:
www-n8n-1         |
www-n8n-1         | (node:6) Warning: Setting the NODE_TLS_REJECT_UNAUTHORIZED environment variable to '0' makes TLS connections and HTTPS requests insecure by disabling certificate verification.
www-n8n-1         | (Use `node --trace-warnings ...` to show where the warning was created)
www-n8n-1         | Owner was set up successfully
www-n8n-1         | User survey updated successfully

Hey @VanLuda,

I had assumed you were just using docker and not compose, your compose file would be useful. Although while the console shows the port can you access it without the port? It might not actually be a problem.

I cannot access n8n without the port. I’ll paste file in the morning. Not near a computer at the moment.

1 Like