ERPNext integration with FrappeCloud is not working

Hello,

N8N (cloud) does not currently work with ERPNext (Cloud/FrappeCloud).
I would gladly subscribe, if your professional support team would do the required updates.

Best regards,
O.

Hey @Ossi,

Welcome to the community :tada:

When you say it isn’t working what do you mean? Do you get any error messages at all?

Thank you for your message. The n8n ERPNext cloud (FrappeCloud) integration does not bring any data from ERPNext. There are no doctypes available. It says DocType Name or ID: “No Data”.

Current ERPNext version is 14.

Cheers,
O

Hey @Ossi,

That is odd, I have just signed up for an ERPNext cloud account and set up the node credentials. I noticed that the credential test fails but the node does list the documents for me.

Just to rule out anything odd can you regenerate your API keys in ERPNext and the first one that appears in the little pop up can you put that in the “API Secret” field in n8n then open the API keys again to view the Key and put that in the “API Key” field. Then make sure your sub domain is only the one part so if your url is https://ossi.erpnext.com/ your sub domain would be ossi.

From there ignore the credential test error (if you get one) and on the document type list click on the 3 dots and select refresh list.

image

Let me know how you get on with this.

Hi,

I’m still having issues. I even made a brand new ERPNext account to test this. The connection seems to be fine, at least it says it’s fine. If i make up new credentials or make up a different address, then it fails.

I still don’t get a list of documents. I have tried refreshing.

Thanks,
O

I have used administrator API keys in ERPNext, if it makes a difference.

Please let me know if i could supplement any information to help you process this.

Currently, I have not set up a full node process as I can’t get forward with this first step. Should I create a full n8n process first or do something in n8n before connecting to ERPNext.

Cheers,
O

Hey @Ossi,

To be honest I am not sure what is going on there, The account I made this morning is working fine so I assume the node itself is ok.

I did my test with the initial account it gave me as well, For science I am going to DM you the subdomain and API credentials for my test account just so we can see if that works for you.

Hi Ossi,
I experience that sometimes too. I managed to get it working checking that parameters:

  1. Check your Frappe URL in the credential settings and try with and without “/”
  2. Try to enter your Doctype name manual instead of waiting for it to be available
  3. Doublecheck the exact permissions of the user which holds the API key (most times a additional user for API calls is recommended to be sure which account does edited your data, at my end just using Administrator account did also not work)

Hope you get it working.

I have found while playing today that it sometimes works and other time ERPNext returns an error. I am not sure what is going on with it but it seems to be internal to ERPNext.

Is there any hint where and how should we fix these issues?

n8n worked with ERPNext for me in the past, but I tried to use it again and I have 2 issues:

  1. Could not connect with self-hosted credential (it’s on frappe cloud, but it should work). So I have to use and save Cloud-hosted option. (both worked in the past).


  2. If I saved this credential, I did not get any data from ERPNext. As you can see the list is empty:

Im on n8n.io cloud and I tested with two different v14 ERPNext (vanilla) hosted both on Frappe Cloud.

I hope you have some idea, bc I don’t know where to investigate…

Hi there @Jon , Can you please share any update here?

Hey @PRASHANT_AGRAWAL,

I have been playing with the ERPNext node recently and have not seen this happen again. Are you seeing the same issue and does the credential test work for you?

Can you also confirm the version of n8n and ERPNext you are using and if it is a custom domain on cloud or self hosted. If it is cloud are you also using the erpnext.com domain or frappe.cloud?

Hi @Jon

Im using Frappe Cloud and i tried both on

ERPNext version 13
&
ERPNext version 14

I even did on fresh installed site for test reasons. In every try the credential pass with success but it is impossible to retrieve any document even by using the refresh under the 3 dots menu

Please help us fix this,
Thanks in advance.

Hey @Chipset,

Welcome to the community :cake:

I have just checked with my Frappe Cloud account and it is still working as expected, Can you try calling the API using an HTTP Request node, Set the URL to https://your-domain.erpnext.com/api/resource/DocType and select your ERP Next credential and send over the response.

Hi @Jon, thank for the instant response.

It is working just fine as HTTP Request i can see the first batch of te documents in the output.

IM guessing that the problem may be the url type ? Because the Frappe Cloud instances are

https://your-domain.frappe.cloud
and not
https://your-domain.erpnext.cloud

Hey @Chipset,

That would do it, Have you tried using a custom domain instead?

@Jon

If you meen to put in the credentials “self hosted” as enviroment, this didnt work.

It fails to connect during the creation of credentials. If i choose cloud based then it passes the credentials test as “my.domain.frappe.cloud” but fails in the document retrival.

Something is totaly borged in the implementation.

Hey @Jon
I can make you a test site in “domain.frappe.cloud” if you need it for tests as i can only come this far.

I suspect this is probably an issue I started fixing a while back but have not yet merged but if you want to DM me some test details I can give it a quick bash.

@Jon

Your site is ready.

Sending you the DM now.

1 Like