ERROR: bind message has 27771 parameter formats but 0 parameters

Hi,
I see that postgresql prints following error message.

ERROR: bind message has 27771 parameter formats but 0 parameters
STATEMENT: SELECT “ExecutionEntity”.“id” AS “ExecutionEntity_id”, “ExecutionEntity”.“mode” AS “ExecutionEntity_mode”, “ExecutionEntity”.“retryOf” AS “ExecutionEntity_retryOf”, “ExecutionEntity”.“status” AS “ExecutionEntity_status”, “ExecutionEntity”.“startedAt” AS “ExecutionEntity_startedAt”, “ExecutionEntity”.“stoppedAt” AS “ExecutionEntity_stoppedAt”, “ExecutionEntity”.“workflowId” AS “ExecutionEntity_workflowId” FROM “public”.“execution_entity” “ExecutionEntity” WHERE ( (“ExecutionEntity”.“id” IN ($1, $2, $3, $4, $5, $6, $7, $8, $9, $10, $11, $12, $13, $14, $15, $16, $17, $18, $19, $20, $21, $22, $23, $24, $25, $26, $27, $28, $29, $30, $31, $32, $33, $34, $35 … … $90000

On n8n web executions section “Problem loading data” pop-up appears under right page. I cant see executions in this section also.

How can I tell n8n to query 100 parameters in stead of more then 90000 ? And how can I see executions.

Describe the problem/error/question

What is the error message (if any)?

ERROR: bind message has 27771 parameter formats but 0 parameters

Please share your workflow

(Select the nodes on your canvas and use the keyboard shortcuts CMD+C/CTRL+C and CMD+V/CTRL+V to copy and paste the workflow.)

Share the output returned by the last node

Information on your n8n setup

  • **n8n version: 1.12.2
  • **Database (default: SQLite):postgresql-15.4
  • **n8n EXECUTIONS_PROCESS setting (default: own, main):main
  • **Running n8n via (Docker, npm, n8n cloud, desktop app):openshift 4.9
  • **Operating system:linux

Hey @Aydemir,

Where are you seeing the error and what are you doing to reproduce it?

This message "ERROR: bind message has 27771 parameter formats but 0 parameters " appears on postgresql container console log and on n8n web ui. According to my understanding It seems that query is too big for postgresql to execute. We tried to find a way of limitin query size in n8n but we couldn find. How can we control execution entry and execution data size? is there a settings for query limit. For example in our case we have $1 to $90000 parameters in select statement. Where this $1 to $90000 comes from. It would be better if it can query parameters from $1 to $1000 for example.

Can you share the workflow maybe so we can see what you are doing?

We purged execution_data table in postgresql to solve this problem temproray. We couldn’t find exact solution right now. Thanks

1 Like