Error n8n in k8s

hello! how are they?
I wanted to tell you that I am having some bugs in n8n installed with K8s, all default (SQLite, n8n version: 0.183.0) One of the many errors is when I finish executing the workflow and I want to start it again, it gives me Request failed with status code error 403, the nodes are well configured since I run it in the same way in a windows installed with .exe and it works correctly. And one of many other errors is when I run the JIRA node and specify that it look for a “ticket status” it gives me the same 403 error and it works for me on windows.

Thank you all!!

Hey @Internalit_Automatio,

Do you have a screenshot of the error you are seeing? A 403 sounds like it could be a network / config issue, Do you have any information on what you set up and how? I have seen issues when reverse proxies are installed but not correctly configured.

If the error is coming back from the node itself then it could be something else, When you run the same way from the windows install is that using the same machine and network configuration as your k8s install? I want to make sure it is testing the same thing and not trying the same test on 2 different machines.

the execution of n8n in K8s is in AWS through CloudFlare and the other .exe environment is Onpremise in a Windows 10. The error I am having is if in the HTTP Request node I put a variable from another node (in my case G Suite Admin in the “Nodes” part) gives me an error when trying to save it, for example:{{$node[“Bring Groups”].json [“email”]}}/members?roles=OWNER gives me an error, now if I manually write the email I want to search for, it lets me save it, but another difference I notice is if I put another “Current Nodes” variable and I get the email from there, it lets me save it.


Console Web:

and with respect to JIRA Software when I place for example: project = “IT Systems” AND “Request Type” = “Google Groups (IS)” it works fine, but if I want to place it, I search for the status for example: “IT Systems” AND “Request Type” = “Google Groups (IS)” AND “status” = “Waiting for Support” does not work for me, it gives me an error in workflow execution and in Onpremise it works fine with the status

Hey @Internalit_Automatio,

Can you tell me more about your setup? For now I think we need to ignore the local instance as you not using the same network or setup so at best all it tells us is n8n is working fine and the issue is with the k8s configuration.

I feel like this is going to be a proxy or cache issue, you mentioned Cloudflare is that set to cache? I would be tempted to try DNS only and see if that changes anything for you.

Hi @Jon
I tried DNS Only and it gave me the same error again, is there a variable that I have to take into account as default? Because the truth is that I find it very strange that I simply do not take a Status in JQL from JIRA Software

Hey @Internalit_Automatio,

There shouldn’t be anything else, I also find it very strange that one instance of n8n is working and another is failing and to me that sounds like if the credentials are the same it can only be the environment :man_shrugging:

The saving I think is down to maybe a reverse proxy config issue, Which proxy do you have directing the requests if any? I assume it was cloud flare to something like nginx

Hi @Jon ,

I found out what the mistake was! It was the WAF, deactivating it everything worked correctly, thank you very much!.