Error on HTTP callout

Describe the problem/error/question

I’m receiving an error of ERROR: Cannot read properties of null (reading ‘name’).
All values are populated and the call isn’t actually made. I’ve tried just calling another generic webhook in n8n (POST method and actively listening) and its the same error as I get when I’m trying to call the third party api. I don’t have anything named “name” as key to send so I’m not even sure whats causing the error.

The n8n session making the call is cloud version and debugging is calling a local n8n session.

Information on your n8n setup

  • **n8n version:.233.1
  • Running n8n via (n8n cloud):

Ok so after trying removing anything that might be null. I have a parameter I’m using the following expression {{ $json.clientEmail || null}}. When I removed the expression from the value it sent to my test webhook listener and was able to successfully send to my third party API. This has worked previously to pass null if no input. Did something change?

Hey @Philip_Wiggins,

I would need to see the full workflow and the data you are using but I don’t believe anything has changed, did you update n8n between it working and not working?

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.