Error response from daemon n8n on DigitalOcean

Hi n8n team,

Describe the problem/error/question
After those commands, when I run the command to start docker compose, it shows the error as below.

What is the error message (if any)?


root@ubuntu-s-1vcpu-1gb-35gb-intel-sfo3-01:~/n8n-docker-caddy# sudo docker compose up -d
[+] Running 1/2
:heavy_check_mark: Container n8n-docker-caddy-n8n-1 Running 0.0s
⠸ Container n8n-docker-caddy-caddy-1 Starting 0.3s
Error response from daemon: failed to create shim task: OCI runtime create failed: runc create failed: unable to start container process: error during container init: error mounting “//n8n-docker-caddy/caddy_config/Caddyfile” to rootfs at “/etc/caddy/Caddyfile”: mount //n8n-docker-caddy/caddy_config/Caddyfile:/etc/caddy/Caddyfile (via /proc/self/fd/6), flags: 0x5000: not a directory: unknown: Are you trying to mount a directory onto a file (or vice-versa)? Check if the specified host path exists and is the expected type

Please share your workflow
I suspect the problem is in the .env file.

Replace with the path where you created folders earlier

DATA_FOLDER=//n8n-docker-caddy

The top level domain to serve from, this should be the same as the subdomain you created above

DOMAIN_NAME=jrpremium.com.br

The subdomain to serve from

SUBDOMAIN=n8n

DOMAIN_NAME and SUBDOMAIN combined decide where n8n will be reachable from

above example would result in: https://n8n.example.com

Optional timezone to set which gets used by Cron-Node by default

If not set New York time will be used

GENERIC_TIMEZONE=America/Sao_Paulo

The email address to use for the SSL certificate creation

[email protected]

Here is my docker-compose.yml, it’s auto-generated, I haven’t made any changes yet.


version: “3.7”

services:
caddy:
image: caddy:latest
restart: unless-stopped
ports:
- “80:80”
- “443:443”
volumes:
- caddy_data:/data
- ${DATA_FOLDER}/caddy_config:/config
- ${DATA_FOLDER}/caddy_config/Caddyfile:/etc/caddy/Caddyfile

n8n:
image: docker.n8n.io/n8nio/n8n
restart: always
ports:
- 5678:5678
environment:
- N8N_HOST=${SUBDOMAIN}.${DOMAIN_NAME}
- N8N_PORT=5678
- N8N_PROTOCOL=https
- NODE_ENV=production
- WEBHOOK_URL=https://${SUBDOMAIN}.${DOMAIN_NAME}/
- GENERIC_TIMEZONE=${GENERIC_TIMEZONE}
volumes:
- n8n_data:/home/node/.n8n
- ${DATA_FOLDER}/local_files:/files

volumes:
caddy_data:
external: true

Please help! Many thanks!

It looks like your topic is missing some important information. Could you provide the following if applicable.

  • n8n version:
  • Database (default: SQLite):
  • n8n EXECUTIONS_PROCESS setting (default: own, main):
  • Running n8n via (Docker, npm, n8n cloud, desktop app):
  • Operating system:

Hi @Robson_Silva2 ,

It appears that the mounting issue is related to the directory path specified in your .env configuration file. To resolve this, update the <directory-path> to point directly to the n8n-docker-caddy directory on your host machine. Your current DATA_FOLDER path is not correct:
//n8n-docker-caddy

Ensure that the specified path exists on your host machine and is indeed a directory. After making these adjustments, run the Docker Compose command again.

2 Likes

This is it, Nice post @tungnguyen249 :raised_hands:

1 Like

Thank you for being interested in helping me, I’m a beginner and some of the information you requested I don’t know where to look for, if you can help me with this, below is what I got

n8n version:
Database (default: SQLite):

n8n EXECUTIONS_PROCESS configuration (default: self, main):

Running n8n via (Docker, npm, n8n cloud, desktop app):
cloud.digitalocean
Operating system: Ubuntu 23.10 x64

Hey @Robson_Silva2,

The solution to this is above.

Did this help you?

Thank you very much
Error resolved

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.