ERROR: The create operation needs input data - Firebase

Using a workflow with only 1 node, Realtime Database.

I have authenticated (however I still had to edit the Postgre DB using this method to get more than 32 chars in the ‘type’ column of the database).

Okay, so my issue is that I can GET the data, but when I try to PUSH or UPDATE it just gives me the error “The create operation needs input data”

I am simply trying to update /total to 4, it’s that simple…

Even though I have put in data, and I have tried several formats (comma separated, raw, JSON, others) nothing works.

Please can you help me understand what is the actual format for the “Columns / Attributes” box in the Realtime Firebase node?

The help documentation is almost a year old and the node is now different and so it is not helpful…

The format ‘seemed’ to be CSV on but that does not work.

Please advise as to the correct method to update a Firebase database. Thank you.

Hey @bocaz, you could use a Set node to format the data as required. Check out the example workflow from our documentation which demonstrates the idea: Create, update, and get a document in Google Cloud Firestore - Workflow -

The workflow can still be used in current n8n versions, even though the documentation was written a while ago.

1 Like

Hi, yes I did try a set node, as it creates JSON (mentioned above) which still doesn’t work (I also wrote some JSON manually).

It works if I just type ‘id, name’ but not if I use ‘Expression’ to get the JSON data from set. Strange.

On another note, the Project ID (on Realtime Node) shows a drop-down, but when I use it, it gives me a 404:

ERROR: The resource you are requesting could not be found 404 Not Found

For example, the project ID is MyDatabase but Realtime node requires MyDatabase-default-rtdb to work.

Hey @bocaz, I have tested the firstore node yesterday and could confirm the project ID dropdown problem. I have added this to the bug report.

That said, the node still works fine when testing this using a workflow like so:

The node runs fine:

And the document is shown in the Firebase console:

Any chance you can share your workflow so I can reproduce the problem you’re having?


As I mentioned in the original post, I only have the firebase node in my workflow, nothing else.

But I should clarify (also in OP) that the node that I’m using is Realtime firebase, not firestore, so it sounds like both nodes have the same dropdown issue.

Using Set works, but using Expression in the Firebase node doesn’t, as per the documentation you linked it needs the name of the item from Set, not the JSON data using Expression. So that part helped. Thank you.

1 Like