Error: There was an error: Cannot find module 'chokidar'

i’m getting this error now since the latest docker image a few mins ago was updated , the docker is now stuck in a boot loop.

Any ideas of the fix?

Are you building your own image by any chance? You might be missing an npm install if so.

I just tried the latest one by running docker run -it --rm -p 5678:5678 -v ~/.n8n:/home/node/.n8n n8nio/n8n:latest and did not run into trouble here:

nope standard docker image, nothing added by me except some environment variables for time zone and stuff.


Are you using the debian container? It looks like the 147 containers are still being built and pushed.

1 Like

i believe it is this one its being pulled from


Does this also happen when using the 0.146.0 tag over latest? E.g. docker run -it --rm -p 5678:5678 -v ~/.n8n:/home/node/.n8n n8nio/n8n:0.146.0?

1 Like

let me try

146 should be fine, Chokidar is used in 147 for the local file monitor trigger.

1 Like

Just checked with @ivov, fix should be coming up shortly with 0.147.1 :slight_smile:

Sorry for the trouble!


no this loads fine

1 Like

Awesome, thanks for confirming! So the best bet would be to stick with 0.146.0 for another hour or so until 0.147.1 becomes available on Docker Hub.

1 Like

i dont remember adding the node and yarn versions, do I still need to have that in there?

These variables are used by the node:14.15-alpine image used by n8n. You wouldn’t have to set them manually - maybe your container management tool shows them automatically?

i just pulled the latest, seems I’m getting same error still

Hm, this is now working fine for me (for both 0.147.1 and latest):

Is your management tool potentially using some cache? Could you try manually setting the 0.147.1 tag?

sure will give it a try

pulling latest i get this

 sudo docker pull n8nio/n8n:latest
latest: Pulling from n8nio/n8n
0a6724ff3fcd: Already exists
3b3c21ce1f8c: Already exists
560ed84bbbcc: Already exists
281a19a6c438: Already exists
ef0b5282b01b: Pull complete
7e8a64901c35: Pull complete
4daeac0c7cbf: Pull complete
88be62efeb25: Pull complete
3a53926893b4: Pull complete
Digest: sha256:b2187484177d32a98834264a59bc8ad1fcb60f0a48f24ecfbeb1d6a62d93cec5
Status: Downloaded newer image for n8nio/n8n:latest

pulling clean

0.147.1: Pulling from n8nio/n8n
Digest: sha256:b2187484177d32a98834264a59bc8ad1fcb60f0a48f24ecfbeb1d6a62d93cec5
Status: Downloaded newer image for n8nio/n8n:0.147.1


appears to be working

1 Like

im going to kill both images and pull latest again, see what happens

had to nuke the old “latest image” and then pull it again for it to start working again on the latest version

1 Like

Awesome, glad to hear this is sorted :slight_smile:

Just out of curiosity, with which tool are you managing your docker containers (I currently use Portainer for my home network, but it’s always interesting to see what other folks use)?

1 Like