Error when using a proxy in the HTTP request node

Did you try from curl to make sure the proxy actually works?

Sorry, didn’t reply to that point, yes it does. I actually use multiple different lists of proxies and always make sure to try them using curl. Yes, the proxy does work, that’s why I think the issue might come from the library the node’s using

That is interesting, I think there can be some odd issues with the library we use but I have given it a test here with a local proxy and it all good.

Makes me think maybe the issue is with the type of proxy, The initial error you reported though is around SSL / TLS versions for that proxy it would have been how you were connecting.

As an example of that if I use an HTTP proxy to connect to a site that is using http but redirects to https I get this…

For my testing I have been using a local squid proxy configured with SSL, Could be worth trying that as well to see if that works. Not that it would solve the issue you are currently seeing but it would at least confirm if a proxy would work on your install.

1 Like

I am also getting the same issue I tried hosting my node project to amazon EC2 Instance it was working fine there but when I try to host it on my dedicated server it drops this error

triggerUncaughtException(err, true /* fromPromise */);

Error: write EPROTO C007F6CD577F0000:error:0A00010B:SSL routines:ssl3_get_record:wrong version number:…/deps/openssl/openssl/ssl/record/ssl3_record.c:355:

at WriteWrap.onWriteComplete [as oncomplete] (node:internal/stream_base_commons:94:16) {

errno: -71,
code: ‘EPROTO’,
syscall: ‘write’

Hey @ommishra,

Welcome to the community :raised_hands:

Which proxy are you using and how do you have n8n configured?

I am using a local squid proxy.

As of now I know it’s not the problem of n8n, It’s the server problem as you said before because I’ve hosted the same nodejs project on my EC2 instance and another on my dedicated server, EC2 Instance is working fine but the dedicated server causing this problem.

I’ve troubleshot many things on the server

  1. Checked my SSL/TLS protocol
  2. Checked whether my SSL certificates are not expired
  3. Scaned for malware and vulnerabilities
  4. Updated OpenSSL
  5. Tried on the Mozilla browser because of Chrome’s recent update
  6. Verified firewall settings (Allowed my nginx)
  7. Checked my IP address reputation
    Everything is perfect.

On the final, I am troubleshooting the SSL Handshake version
And I think this might be the thing which is causing this issue.