Eventbrite Integration: "Bad request" out of the box

Describe the problem/error/question

I’m attempting to set up an Eventbrite trigger, but the Eventbrite node is throwing an error whenever I test it.

The only node I’m using is the “Eventbrite Trigger” node. I’ve authenticated using OAuth2, which successfully connected. I can see my “Organization Name” and “Event Names” in the dropdowns, so the connection seems to be working.

Then I select one or more “actions”, and click “Test step”. It always throws the error below.

I’ve tried authenticating via the private key method instead, but get the same results.
I’ve also tried with “Resolve Data” both on and off, but same results.

What is the error message (if any)?

Problem running workflow
*Bad request - please check your parameters*

Show Details

Eventbrite Trigger: 400 - {"status_code":400,"error_detail":{"ARGUMENTS_ERROR":{"endpoint_url":["INVALID"]}},"error_description":"There are errors with your arguments: endpoint_url - INVALID","error":"ARGUMENTS_ERROR"} - ARGUMENTS_ERROR

I’m a little confused how to proceed, because it seems like the Eventbrite API doesn’t like how the request is formatted, but the request is being handled by n8n. Should I be doing something else here?

Please share your workflow

Share the output returned by the last node

Information on your n8n setup

  • n8n version: 1.29.1
  • Database (default: SQLite): I didn’t change the default, so I’m guessing SQLite?
  • n8n EXECUTIONS_PROCESS setting (default: own, main): How to I check this?
  • Running n8n via (Docker, npm, n8n cloud, desktop app): Docker
  • Operating system: UNRAID

It looks like your topic is missing some important information. Could you provide the following if applicable.

  • n8n version:
  • Database (default: SQLite):
  • n8n EXECUTIONS_PROCESS setting (default: own, main):
  • Running n8n via (Docker, npm, n8n cloud, desktop app):
  • Operating system:

Hi @rikkitikkitavi :wave: Welcome to the community :tada:

I can’t reproduce this - can you make sure your localhost URL is correct?

It turns out it was an issue with making my webhooks available outside my network! Got them properly set up in Cloudflare and it’s working now. Thanks!

2 Likes

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.