Executions data save on success false still executes sql statements?

Describe the problem/error/question

hi, i’ve set export EXECUTIONS_DATA_SAVE_ON_SUCCESS=none via environment variables.
did source .bashrc
stopped/started n8n
have a single active workflow
after the executions are run (all are success, assume just a dummy workflow), when i check from sqlite; SELECT count(*) from execution_entity ee; i get 0 rows (which is expected as far as i understand)
but when i check n8n logs i see;

query is slow: UPDATE “execution_entity” SET “status” = …
query is slow: INSERT INTO “execution_entity”(“id”, …
query is slow: SELECT “WorkflowEntity”.“staticData” AS …

is it normal for these queries to run, since when i SELECT count(*) from execution_entity ee; i get 0 row, but there is the log for insert into execution_entity ?

What is the error message (if any)?

Please share your workflow

(Select the nodes on your canvas and use the keyboard shortcuts CMD+C/CTRL+C and CMD+V/CTRL+V to copy and paste the workflow.)

Share the output returned by the last node

Information on your n8n setup

  • n8n version: 0.222.3
  • Database (default: SQLite): default SQLite
  • n8n EXECUTIONS_PROCESS setting (default: own, main): default own
  • Running n8n via (Docker, npm, n8n cloud, desktop app): npm
  • Operating system: linux opensuse 15.4

Hi @slenderwrist, welcome to the community! n8n would still use the database to indicate an execution is running with this setting, but it would not persist the actual execution data.

You could increase the slow query threshold to get rid of these “query is slow” messages by adjusting the DB_LOGGING_MAX_EXECUTION_TIME environment variable.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.