Executions screen near empty even with executions happening

I have more than one hundred workflows running selfhosted for many months.

In many cases, the Executions screen is empty or displays only the last few days, even though I have proof that it has been running on schedule for weeks.

Any sugestions on how to troubleshoot this?

Information on your n8n setup

  • n8n version: 1.26.0
  • Database (default: SQLite): sql lite
  • n8n EXECUTIONS_PROCESS setting (default: own, main): main
  • Running n8n via (Docker, npm, n8n cloud, desktop app): docker
  • Operating system: ubuntu

Hey @fxholl,

That is possibly a good thing, If you have hundreds of workflows running and you are saving all executions on SQLite you will eventually have a bad time.

We have a default option that removes data after 14 days or 10000 records, It could be worth checking your env options to see if you tweaked any of the settings. I would look for EXECUTIONS_DATA_MAX_AGE as a starting point but you can find others here: Environment variables reference | n8n Docs

1 Like