Failed executions not saving

Describe the problem/error/question

I noticed that if I select “Do not save successful executions” then Failed exeuctions are not being either saved…

Information on your n8n setup

  • n8n version: 1.16.0
  • Database (default: SQLite): Postgresql
  • n8n EXECUTIONS_PROCESS setting (default: own, main): queue
  • Running n8n via (Docker, npm, n8n cloud, desktop app): docker
  • Operating system: gcloud/linux

Hi @yukyo, I am sorry you’re having trouble.

I just gave this a go on my own n8n instance running 1.21.1 and using the below workflow:

My workflow settings reflect yours:

The executions are, however, saved as expected for me when calling the production URL of my webhook node:

Can you confirm if this is still happening for you on n8n 1.21.1 or later? If so, can you share an example workflow and confirm how exactly you are triggering it?

Hi @MutedJam, I checked in 1.16.0 and can confirm when a workflow FAILS doesn’t get saved.

I upgraded to the latest version, 1.20.0, and now failed workflows GET SAVED correctly, and I can see them in the execution list.

Also, the errors from Postgresql are gone with this new version.

1 Like