Filter node operation equal does not work

Describe the problem/error/question

When using the filter node it seems like the operation equal does not work. We try to match a code from another node. The code is exactly the same but the operation only works with contains and not with equal. Does any body else have this problem?

Kind regards,

Tim Evers

Hi @timautomation, I am very sorry you’re having trouble. It’d be great if you could fill out the full template when posting a new question here on the forum to help understand and reproduce your problem. Based on your description I suspect there could be a special character or whitespace somewhere in your field.

In general, the equal operation worked fine for me when testing it just now on [email protected]:

My example data is sent to the “Keep” branch as it should when comparing a field from a previous node. This was using the below workflow:

So perhaps you can share an example workflow using which your problem can be reproduced and confirm the exact version of n8n you are using?

Hi Muted Jam, thanks for the answer. We use version: 0.225.2

This is a screenshot of the problem, i cannot share the workflow, as it contains sensitive data…
You can see that it recognises ALFA-002 but it evaluates as discarded/false. We cannot figure out why. With the contains opertation it works fine.

This looks like there might be a line break in your Value 2 field causing it to differ from what you have in Value 1. Can you make sure there are no trailing/leading white spaces or other characters in your expressions?

If the problem still persists, can you share the JSON data from each node you are comparing data from? You can copy the actual data by selecting the top line in the JSON view, then use Copy → Copy Selection:

1 Like

You were very sharp yesterday :wink: There was a linebreak in Value 2 field! That solved the problem!

Thanks a lot. have a great day

1 Like

Glad to hear it was just that! Thanks so much for confirming :bowing_man:

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.