Front-end Freezing Issue During Workflow Test Execution on Self-Hosted N8n

Hi n8n Community,

I am currently facing an issue with our self-hosted N8n instance. This problem has persisted across multiple versions. When we try to run a test on the front-end, the workflow execution appears to be stuck. Specifically, after triggering the test execution of a node, the front-end interface freezes, preventing further testing or implementation. However, upon checking the “executions” section, I can confirm that the execution is indeed happening in the back-end.

I am seeking assistance to understand how to properly configure N8n to avoid this issue. Any insights or guidance on how to resolve this front-end freezing problem while ensuring that the back-end execution functions smoothly would be greatly appreciated.

Thank you in advance for your support.

It looks like your topic is missing some important information. Could you provide the following if applicable.

  • n8n version:
  • Database (default: SQLite):
  • n8n EXECUTIONS_PROCESS setting (default: own, main):
  • Running n8n via (Docker, npm, n8n cloud, desktop app):
  • Operating system:
  • n8n version: “1.45.1”
  • Database (default: SQLite): PostgreSQL
  • n8n EXECUTIONS_PROCESS setting (default: own, main): main
  • Running n8n via (Docker, npm, n8n cloud, desktop app): k8s
  • Operating system:

Hey @_LT, thanks for reaching out. Could you share a video of this happening? Additionally, since you are self-hosting, you could increase the verbosity of n8n’s logging. Feel free to share logging from the period your recording covers and we can take a deeper look.


in fact it is not configured =/


Freezing Editor | n8n - Watch Video

The loom video i ve recorded.

I have the same issue, it only started happening after I setup nginx for https

Hi @_LT and @Francisco_Saavedra

if you are using nginx you will have to configure the websockets.

server {
  listen 443 ssl;
  server_name n8n.my_domain.tld;
  location / {
    proxy_pass http://127.0.0.1:5678;
    proxy_set_header Connection 'Upgrade';
    proxy_set_header Upgrade $http_upgrade;
    proxy_http_version 1.1;
  }
  ssl_certificate # removed
  ssl_certificate_key # removed
}

:bulb: More Info: NGINX as a WebSocket Proxy

Hi @ria

Thank you for the solution! We are using Traefik instead of Nginx. Could you please provide an example configuration for Traefik to handle WebSockets?

Thanks in advance!

Hi @vianavnx

You shouldn’t need any specific config for Traefik to handle WebSockets. Are you seeing any issues with it?

Yes, its the same issue of the OP. And i was thinking its probably the same solution

@ria Do you know what might be causing this behavior even when using Traefik? thanks

Hi @vianavnx

Are you only using Traefik or nginx as well?

What kind of errors do you see in the Browser Dev Tools?