GitHub star in Rocket chat

Hello, Im new user your product. Recently i tried notificaton on GitHub star in Rocket chat. But its different from tutorial video. I created if conditions but its no input data section like tutorial video. What can i do?

If you see no data in the variable selector then you have to run the trigger and do the action that triggers the event. So that the trigger receives the data that you will be able to use on the Rocket chat node.

Let me know if that helps and any further questions you might have.

Regards

Ricardo.

1 Like

Yep, i run the trigger and did the github star action like video. But its no difference. Did i connect github Credentials incorrectly?

Does the trigger node get called after you add/remove the star on Github or does it keep on loading till it times out after 120 seconds? Only if the node shows the green 1 in the corner, did it receive information (like in the video).

If that does not happen, my best guess (without any further information) would be that you do not start n8n with tunnel and so it uses “localhost”. This would result in Github not being able to “reach” your n8n-instance.

1 Like

When i click execute workflow it takes 1-3 sec then n8n2 green 1 on start node not github trigger.

That is very strange. That should not happen. Normally it should recognize that there is a Trigger-Node in the workflow and then wait till it gets fired and so ignore the Start-Node. So after you click on “Execute Workflow” it should change to “Waiting for Webhook-Call” and then stay like that till it receives either that call (like when you add/remove a star) or until it times out after 120 seconds.

Just to be sure. Are you using the latest n8n version?

What you could try is to hover over the Github Trigger-Node and then press on the “play” button which appears over the node instead.

Im not developer. So please help me, how to get right credentials from github. I think didn’t get rigth credentials.

  1. Settings
  2. Developer settings
  3. Personal access tokens
    This is where i got the code.

Yes, that is correct.

What problem do you have?

Did you make sure that n8n is web-accessible (like if you run it locally you started it with the tunnel)? And does your user have access to the repository you want to listen to events off?

Yep

  1. Its web-accessible. Our IT teams build it.
  2. Im owner and admin at my respository.
    Can you make screenrecorded example video for this? I want to connect rocket chat private channel. When github account taking star, our rocketchat channel gettin message.

What is the problem you are having? What error message does it display you?

That does not sound like there is anything wrong with the credentials. If there would, you would get an error message.

It sounds more like the “Github Trigger” node is disabled. Because if it would not be, it should choose to start the workflow from it instead of the Start-Node. Is the node really active? What happens if you press the “play” button directly on the node?

And also the same question which I asked on the 6th of March. Are you using the latest n8n version?

What is the number of the latest version? We’re just using the so-called latest version.

The currently latest version is 0.63.0.

I asked developers. We using 0.63.0. verstion.

Then lets circle back to the web accessible.

Is it set up to use a proper domain-name (like: example.com) or does it use an IP address like (127.0.0.1)? Additionally, is it configured to use SSL (so the URL starts with “https” and not “http”)?

https://n8n.erxes.io/ that is our link

It looks like the SSL certificate is not valid for this subdomain. That would sadly be a problem with many webhooks as they by default expect a valid one.

You can create one automatically and free with Lets Encrypt like described here:
https://docs.n8n.io/#/server-setup

Btw. really cool project! Maybe be will start to use it ourselves soon.

I sent a request to the developers to resolve this.
Yep,Try ours. We look forward to working with you.

1 Like