Google calendar trigger not triggering for some events

Hi guys!

I have a workflow that starts with a google calendar trigger for new events, as below:

For most events this works fine, but for some reason some of them don’t trigger the node.

I’ll give you an example:

Below is the invite I received for an event last Monday, August 8th, at 10:41 PM.

Below are the execution logs for my workflow that is triggered by a new event in google calendar.

As you can see, for some reason it did not trigger.

I’ve thought about maybe being related to the event being generated by someone outside my organization (which is the case), but I’ve tried that in other scenarios and it worked fine, so doesn’t seem to be the reason.

The node works for almost 100% of cases, but once in a while this case turns up and is really annoying because it makes me not trust blindly my time management system (to which the new event data is uploaded).

My n8n version is 0.184.0 and is run on our Digital Ocean cloud server (not sure if NPM or Docker, but I can check if necessary).

Any ideas on what could be wrong?

Thanks in advance,

Daniel

Hi @Daniel_Barra, many thanks for reporting this! I’ll see if I can reproduce this and will report back.

Hi @Daniel_Barra, I tested a bit and could reproduce this.

The Google Calendar Trigger node would not trigger for “Event Created” when you’re being invited to an older existing event created by someone else. In such cases, the created date of the event (which is what the node uses to identify new events) remains whatever it was when the event owner first created it.

So to have your trigger run for these events as well you would need to pick Event Updated in the Trigger On field of your node (as the updated timestamp of such an event does change in the aforementioned case).

1 Like

Nailed it!

That is exactly what was happening. A few minor adjustments and now it seems to be working perfectly.

Thank you so much! @MutedJam

1 Like